JFBuild Technical Details

System Requirements

The following hardware and software requirements should be met to best support JFBuild:

Operating SystemWindows 95/98/Me/2000/XP
Linux with kernel 2.2 or newer
BSD (eg. Free/Open/Net)
Mac OS X 10.2 or newer
Solaris 9 and 10, BeOS 5, QNX 6.2.1, and SkyOS 5 are casually supported
ProcessorPentium-class x86 or better (minimum Pentium 233MMX recommended)
PowerPC G3 or better
UltraSPARC IIi (may work on other models of SPARC, but have not been tested)
GraphicsOpenGL-capable card highly recommended

To compile the source you will need:

WindowsMicrosoft Visual C++ 6.0 or newer
or OpenWatcom 1.2 or better
or MinGW32 (GCC 2.95.3 or newer)
DirectX 6 SDK or newer
Mac OS XMac OS X Tiger (10.4) with Xcode 2.4
Other PlatformsGCC 2.95.3 or better
SDL 1.2

Downloads

Available on this site is a snapshot of the source and the binaries built from that snapshot. The files are available from the JFBuild download area. Here is the README file packaged in the binary and source archives for more details on what you need.

Head to the new downloads area for links to the files.

You will need both the binaries and game data archives to run the port. Extract both archives to the same location on your harddisk.

The game data is the property of Ken Silverman. You can get the original source that this port is based off from Ken's site.

Bugs

I'm slowly squashing them and I've found things to be very stable now, however there may still be issues, and if you have any I'd appreciate hearing about them. Send me as much information about your computer, and what I need to do to reproduce any errors.

Contacting Me

I can be contacted via email at jf@jonof.id.au. I welcome and encourage any bug reports or suggestions for improvement.

with at least DirectX 6 installed
All trademarks and copyrighted materials are the properties of their respective owners. Copyright © 2004-2005 Jonathon Fowler.
Page generated in 0.000667 seconds with 0 database queries. Validate markup.