JFDuke3D/JFShadowWarrior Frequently (or not) Asked Questions

Index

  1. I can't pan textures in the Build editor by pressing Shift + Numpad arrows
  2. What do I need to run your ports?
  3. The ports won't run on Windows PE.
  4. Will your port run on Windows 98?
  5. When will joystick support be added?
  6. When will OpenGL/Direct3D support be done?
  7. When will multiplayer be finished?
  8. Mouse looking doesn't work.
  9. Duke/Lo Wang keeps strafing to the right!
  10. I have an Intel-based graphics card and all I get is a black screen in Polymost mode. No status bar, no nothing. Why?

I can't pan textures in the Build editor by pressing Shift + Numpad arrows

You have to start the Build editor with Numlock turned OFF. Since the key to activate the Build console is Numlock by default, pressing it while the editor is running only succeeds in opening the console, and Numlock will be reenabled when you press it again to close the console.

An alternative solution is to change the console key to, say, Scroll Lock, which releases the Numlock key so you can turn it off while the editor runs. To do this, open build.cfg in a text editor and change the 'keyconsole' value from 45 to 46.

What do I need to run your ports?

At least a Pentium 133 with 32MB of RAM is required in the hardware stakes. A mouse and keyboard, a VGA monitor and video card capable of displaying at least 256 colours are also somewhat handy. The minimum Operating System requirement is Windows 95B with DirectX 7.0.

The ports won't run on Windows PE.

That is correct. WinPE apparently doesn't ship with DirectX, so you're out of luck.

Will your port run on Windows 98?

Yes.

When will joystick support be added?

Fairly decent support now exists. It will improve in the future though.

When will OpenGL/Direct3D support be done?

Now. Ken has released his Polymost renderer as of December 23, 2003 and it supports OpenGL.

When will multiplayer be finished?

A multiplayer test is out now. Give it a go.

Mouse looking doesn't work.

There are two possible reasons I know of why this can happen:

  1. You've messed with the Advanced Mouse settings in Setup and changed the Analogue Y Axis mapping from "analog_moving" and/or you changed the Analogue X Axis mapping from "analog_turning".
  2. You haven't enabled mouselook in the game.

Duke/Lo Wang keeps strafing to the right!

Something about your joystick is confusing the input code. I haven't found out what is at fault yet but there are two solutions: (1) unplug your joystick, or (2) in the game find in the menus "Options → Joystick Setup → Edit Axes → Next → Rudder Scale" and move the slider to the 0 position. Hopefully that will stop it strafing. You won't be able to use the rudder though.

I have an Intel-based graphics card and all I get is a black screen in Polymost mode. No status bar, no nothing. Why?

This actually shouldn't be a problem anymore in the newer releases. There have been issues with certain video chipsets or drivers misrendering fog as being too dense (SiS and Voodoo cards in particular), but that's a different issue which I'm trying to figure out. If you're getting a completely black screen still, email me.

All trademarks and copyrighted materials are the properties of their respective owners. Copyright © 2004-2005 Jonathon Fowler.
Page generated in 0.000571 seconds with 0 database queries. Validate markup.